January 5th, 2016

Неужели каюк?

С середины декабря комп начал подавать признаки смертельной усталости.
Вот для начала мои параметры: АМD Аthlon 2600+, 1,92 ГГц, ОЗУ 1 Гб, NVidia NForce MCP2, ATI Radeon 9600/X1050, два винчестера (10/10 Гб и 55/55 Гб), WindowsXP Professional SP3 (естественно левый с файлом-взломщиком). Компьютер сам возрастом около 8 лет, системный винчестер около 10 лет. Проверка на целостность винта показало его практически отличное состояние.
После начала загрузки, когда появляется эмблема Виндоуса и бежит внизу синий бегунок, вдруг все темнеет и через секунду выдается синий экран смерти. На нем среди кучи текста присутствует следующее:
driver_irql_not_less_or_equal
...
stop 0x00000d1 (......)
atapi.sys _address f7477688 base at f747200 datestamp 4802539d

Вот примерно такое. То есть, как я понял, какой-то сбой в драйвере atapi.sys. Размер файла соответствует исходному, дата изменения - 2008 год, когда я ставил систему.
Поискал в сети. Там советуют переставить планки оперативки в другие гнезда. Что я и сделал (у меня одна планка). Предварительно протерев всю пыль на планке и вообще в машине. Не помогло.
Еще совет - переустановить систему. Так как у меня винт небольшой, я просто взял диск с третьим сервиспаком и поставил поверх (исходного дистрибутива системы ХР у меня нет). После этого комп начал немного медленнее загружаться, причем светодиоды над цифровой клавой загораются, потом все гаснут, потом опять включаются (НамЛок). Но и переустановка системы не помогла. Кстати, опять стал возникать завис компа: просто не реагирует и все, ни на мышку, ни на клаву, и диод работы винта не показывает активность. Приходится нажимать резет. Подобная картина как-то давно была, но постепенно она ушла.
Тотальная проверка на вирусы (пришлось удались проги от Ауслогик по очистке реестра и дефрагментации, потому что ДрВеб посчитал их вирусными) тоже не помогла. Был найден какой-то регулярно появляющийся файл si.exe в папке wi_upd (в Документы и Сеттинги / Сергей / Аппдикейшен Дата), определенный как вирусный.
Комп сначала после загрузки системы выдает синий экран, а вот после резета уже загружается, причем через черный экран выбора вида загрузки системы (автоматом стоит на обычном режиме загрузки).
Как обновлять драйвера, я не знаю. В инете atapi.sys самый новый соответствует тому, что у меня установлен.
Теперь возникают вопросы:
1) Какова вероятность накрывания компа медным тазом и в какие сроки?
2) В чем же причина таких сбоев?
3) Как можно при минимальных затратах (а денег сейчас катастрофически нету) исправить ситуацию? Может фару протереть или колесо попинать? Кто подскажет?